Forums - La Blocothèque - Sous-titres disponibles, mais pas par défaut.

Mots-clés : 

Ce sujet a 3 réponses, 2 participants et a été mis à jour par   Roxanne SAVARD, il y a 1 mois et 2 semaines. This post has been viewed 82 times

  • Roxanne SAVARD  | Posté le 20 août 2020 à 14 h 21 min

    Bonjour,

    Je souhaite rendre les sous-titres disponibles par l’accès au menu, mais je ne veux pas qu’ils apparaissent par défaut lors du début de l’expérience.

    La commande en bloc variable « allowSubtitles (true) » rend les sous-titres visibles sans l’avoir sélectionné dans le menu.

    Quelle commande puis-je inscrire pour les rendre disponibles seulement si l’apprenant va dans le menu pour les activer ?

    Merci

    Shams Cavelier  | Posté le 25 août 2020 à 16 h 59 min

    Bonjour Madame Savard,

    Vous pourrez utiliser la fonction allowSubtitles() en mettant false entre les parenthèses pour désactiver les sous-titres dès le début de l’expérience, en tout début de cette dernière.

    Il sera pertinent, à la suite de ce tout premier bloc Variables contenant la fonction, de placer un bloc Message (ou Diaporama) informant l’apprenant qu’il a la possibilité d’activer les sous-titres.

    J’espère que cette information saura vous être utile, et je vous souhaite une très agréable conception avec VTS Editor !

    Bien cordialement,

    Shams,
    De l’équipe Support de Virtual Training Suite

    Roxanne SAVARD  | Posté le 31 août 2020 à 17 h 32 min

    Bonjour,

    Malheureusement, si je remplace « true » par « false » entre les parenthèses de « allowSubtitles() » tel que vous me le conseillez, les sous-titres n’apparaissent pas lorsque l’option sous-titre est activé dans le menu.

    Le bloc variable « allowSubtitles (true) » rend les sous-titres visibles par défaut dès le départ du scénario et le bloc variable « allowSubtitles (false) » rend les sous-titres indisponibles, et ce, même si l’option des sous-titres est activée par la suite dans le menu de l’expérience.

    Est-ce un bug?

    Roxanne SAVARD  | Posté le 31 août 2020 à 17 h 59 min

    Bonjour,

    Simplement pour vous aviser que j’ai résolu ma problématique.

    Merci